renaming the ">" operator

Adrian Thurston thurs... at
Fri Jul 20 18:58:33 UTC 2007


Looking at a couple discussions on this list I realize that the ">"
operator needs to be renamed. The current name "entering" suggests that
it is symmetrical with the leaving operator. In fact, it once was, so
back then it was a good name.

But the semantics have since changed and the name should have been
changed along with the semantics. Since it is now closer to being
symmetrical with the finishing transition operator it should be named

So now the transition-based embedding operators are like this:

">" - starting a machine - transitions leaving the start state
"@" - finishing a machine - transitions into a final state
"%" - leaving a machine - transitions out of a final state
"$" - all transitions

Now in the case that the start state is final we can say that it is
possible to "leave" the machine without ever "starting" it and it
doesn't sound as much like a contradiction. After all, you can leave a
lot of things without actually starting them :)


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 252 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the ragel-users mailing list